PySide GUI 绑定 Qt for Python (GUI 开发框架)


开发工具


数字 Python IDE     数字 IDE 专业版


PySide 安装包

 

PySide 现由 Qt/C++ 官方直接维护并提供技术支持,官方工程名为 Qt for Python。

Qt 是奇趣科技于 1991 年开发的跨平台 C++ 图形用户界面应用程序开发框架,目前分 GPL、LGPL2.1-3、商业许可授权协议版本。Qt 向应用程序开发者提供了建立艺术级图形用户界面所需的所有功能,可用于开发 GUI 程序,也可开发非 GUI 程序,譬如:控制台工具、服务器。Qt 开发框架是面向对象的,它使用特殊代码生成扩展(称为元对象编译器 Meta Object Compiler, MOC)及一些宏,易于扩展,允许组件编程。


PySide 包括快速生成任何基于 Qt 的 C++ 类层次结构绑定的完整工具链。PySide 的 Qt 绑定允许自由开源软件和专有软件开发,最终目标是支持 Qt 平台。

PySide 是跨平台的 Gui 应用程式框架 Qt/C++ 的 Python 绑定版。PySide 能提供和 PyQt 类似的功能,但与 PyQt 采用 GPL 及商业双授权模式不同,PySide 使用 LGPL 许可协议。PyQt 由 Riverbank Computing 有限公司负责开发,提供服务。

内容表

上一话题

PySide GUI 绑定

下一话题

PySide GUI 绑定

 

快速搜索

兼容列表

Python Linux 32bits Linux 64bits macOS 32bits macOS 64bits Windows 32bits Windows 64bits
2.7 支持 支持
3.5+ 支持 支持 支持 支持

版本历史

日期 版本 说明 备注
2018.12 2.0

支持 Qt/C++ 5.12

微软 Windows 平台兼容 Python3.5 3.6 3.7 以上版本 (采用 MSVC2015 构建)

2018.06 2.0

支持 Qt/C++ 5.11

Web 核心由 Apple Safari 改为 Google Chromium

微软 Windows 平台兼容 Python3.5 3.6 3.7 以上版本 (采用 MSVC2015 构建)

由 Qt/C++ 官方直接维护并提供技术支持

官方工程名改为 Qt for Python

2015.10 1.2.4

支持 Qt/C++ 4.8.7

兼容 Python2.6 2.7 (采用 MSVC2008 构建)

兼容 Python3.3 3.4 (采用 MSVC2010 构建)

存在一些重要 Bug,譬如:QWebView 点击某些 JavaScript 链接无响应、某些链接不弹出窗口、

某些 PNG 图片无法展示;粘贴修改交互 Web 内容,如:自动变行、插入位置不对、自动设置字体颜色 color=#000

最后一个 PySide 1.0 发布版
2013.08 1.2.1 支持 Qt/C++ 4.8
2009.08 1.0 首次发布

使用 LGPL 许可协议

由开源社区负责开发,提供服务

 

更新时间: 2020.03.30

版权声明: 本文为独家原创稿件,版权归 乐数软件 ,未经许可不得转载;否则,将追究其法律责任。